Imagemagick and its delegate libraries

You need ImageMagick in order to get ruby gems such as Paperclip, or Rmagick, etc to work properly. ImageMagick is one of the most feared dependencies since even if you correctly install it, you may still get errors like:


“is not recognized by the ‘identify’ command”

This is because “identify”, a command that comes in the ImageMagick suite (in addition to “convert”), requires special libraries to understand different image formats. These special libraries are called “delegates”.


You can see all the delegates set up to work with your current ImageMagick with this command:


convert -list configure

All the delegates are available at this link:


http://www.imagemagick.org/download/delegates/


There are 2 that you need for jpeg: Jasper and Jpeg


Grab any that you need, ./configure, make, sudo make install


Now you need to recompile ImageMagick and make sure it works with these delegate libraries:


./configure –enable-delegate-build –enable-shared –disable-static \
–with-modules –with-quantum-depth=16 –without-wmf \
–enable-libtool-verbose –disable-dependency-tracking \
–with-gs-font-dir=/usr/local/share/ghostscript/fonts/ –with-lqr
make
sudo make install

You should hopefully see your delegates–if not at least you know about them now and can troubleshoot further–enjoy.